VMware Workstation 14 - Authorization Service Error

Introduction

I started VMware Workstation (Windows, v14.1.2 build-8497320) tonight and when I tried to start a VM I was getting the following error:

Workstation Error

Here is how I fixed it.

Troubleshooting

The error message above is pretty self-explanatory. I checked the services:

Workstation Error

Sure enough it wasn’t started. I tried to start it but it failed to start. So I checked the System Event Log:

Log Name:      System
Source:        Service Control Manager
Date:          29/05/2018 19:18:43
Event ID:      7024
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      P500
Description:
The VMware Authorization Service service terminated with the following service-specific error: 
%%6000009

Googling the error led to a couple of links:

Manfreds blog post was the closest to the error but this was not a fresh upgrade to v14 and the vmmon driver was at the v14 level.

After thinking about it the only thing I had done recently was to apply the Windows 10 update KB4100403 which updated the OS to build 17134.81.

The Fix

In the end I went with the rather unsatisfactory (to me anyway) fix of running a Repair of the Workstation install and then rebooting the computer.

After that the VMware Authorization Service service was started Automatically and I could start VM’s.

As I said I am not really satisfied with the fix as I don’t understand why the service wouldn’t start, but in the end a quick fix is sometimes the best thing.

Hoping this helps someone out there.

Categories:

Updated: